// Allows an iframe running on another domain to access query strings on this page

News & Information

CyberSafe TrustBroker™ products, for SAP business applications

CyberSafe TrustBroker Support Services

SAP Database Product Compatability

Overview

The TrustBroker Secure Client product includes Kerberos libraries which are certified, tested and supported by CyberSafe for use with certain database products from SAP (the products which were originally from the company known as Sybase, before SAP acquired the Sybase company). TrustBroker uses the Kerberos protocol instead of sending the users password over the network to the database. It can also be used to add data integrity and encryption to the database communications.

Often companies already have a Microsoft Active Directory domain infrastructure, and TrustBroker can fully utilize the Active Directory domain controllers when authenticating users, and providing Secure Single Sign-On.

SAP Adaptive Server Enterprise (ASE) Version 15.x and 16.x
SAP Open Client-Server (OCS) Version 15.x and 16.x

Platforms & Product Versions Supported

This table shows the operating systems and architectures which the SAP ASE and OCS products are supported on, and which version of TrustBroker Secure Client, Active Directory or TrustBroker Security Server products are supported.

Older versions of TrustBroker products may also be supported, but these are the recommended versions. Please contact us if you want to check compatibility or discuss your requirements.

Operating System Architectures TrustBroker Secure Client  Microsoft Active Directory 

TrustBroker Security Server 

Windows Server 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 x86, x86_64 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
Windows XP SP2/SP3, Windows Vista, Windows 7, Windows 8 x86, x86_64 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
Oracle Solaris 9, 10 or 11 Sparc (64-bit) 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
Oracle Solaris 10 or 11 x86_64 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
IBM AIX 5, 6 or 7 PowerPC (64-bit) 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
RedHat Linux 4, 5 or 6 x86_64, PowerPC 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
SuSE Linux 9, 10 or 11 x86_64, PowerPC 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
Hewlett Packard HP-UX Itanium 11i v2 or v3 IA-64 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later

Notes:

  • The TrustBroker Secure Client product includes a commercially supported GSS-API Version 2 Kerberos library, which is used by the SAP ASE product for authentication, and communication security.
  • As well as a TrustBroker Secure Client license from CyberSafe, a license is required for the "Security & Directory Services Option" and is available from SAP.
  • The Microsoft Active Directory product is used as a Kerberos Authentication Server (KDC) and is often already deployed in a customers network. This is the preferred KDC. If it is not possible to use Active Directory, CyberSafe can supply a KDC product called TrustBroker Security Server.

SAP SQL Anywhere Version 10,11 or 12

Platforms & Product Versions Supported

This table shows the operating systems and architectures which the SAP SQL Anywhere product is supported on, and which version of TrustBroker Secure Client, Active Directory or TrustBroker Security Server products are supported.

Older versions of TrustBroker products may also be supported, but these are the recommended versions. Please contact us if you want to check compatibility or discuss your requirements.

Operating SystemArchitecturesTrustBroker Secure Client Microsoft Active Directory 

TrustBroker Security Server 

Windows Server 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 x86, x86_64 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
Windows XP SP2/SP3, Windows Vista, Windows 7, Windows 8 x86, x86_64 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
Oracle Solaris 9, 10 or 11 Sparc (64-bit) 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
Oracle Solaris 10 or 11 x86_64 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
IBM AIX 5, 6 or 7 PowerPC (64-bit) 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
RedHat Linux 4, 5 or 6 x86_64, PowerPC 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
SuSE Linux 9, 10 or 11 x86_64, PowerPC 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
Hewlett Packard HP-UX Itanium 11i v2 or v3 IA-64 4.3.1 or later 2000, 2003, 2003 R2, 2008, 2008 R2, 2012, 2012 R2 4.3.1 or later
Leave us a message, or ask a question   CyberSafe on Twitter  CyberSafe on LinkedIn  CyberSafe on YouTube